NJFBOA - Home of New Jersey's Camaros and Firebirds

NJFBOA - Home of New Jersey's Camaros and Firebirds (http://www.njfboa.org/forums/index.php)
-   Engine / Power / Tuning (http://www.njfboa.org/forums/forumdisplay.php?f=31)
-   -   Quadrajet lean bog secondaries (http://www.njfboa.org/forums/showthread.php?t=69355)

alamantia 06-29-2022 09:11 AM

Quadrajet lean bog secondaries
 
1 Attachment(s)
For any of the people on here with some Quadrajet experience perhaps you can point me in the right direction.

I bought a used boat about 3 years ago and it has a 454 with a spread bore manifold with an adapter plate to a square bore Webber. At first I thought that was installed by the previous owner but I soon learned by viewing the parts diagrams for my engine thats actually what Mercruiser did in the early 90's I can only guess they were buying long blocks from GM with spread-bore manifolds and unable to buy Rochesters for them in 1992 so they went the Webber route with an adapter.

The Webber was old and leaking down and hard to start so rather than buying another square-bore carb I thought it proper to just buy a marine Quadrajet. I found a rebuilt 454 marine Rochester online from national carburetor and installed it last season. It runs fine other than a dead spot (bog) when the secondaries kick in. Sometimes I even hear a small backfire if I throttle up too fast from a dead stop.

I checked the squirt that I got from the accelerator pump by looking down the primaries when the engine was off and it squirts fine.

I checked the timing and it is at 10 DEG BTC s per the manual states.

Here is what i did so far.

1. Adjusted the spring tension on the secondary air doors so much that I broke the spring and had to order a new one. Installed new spring and I have it very tight and it still bogs.

2. Removed the secondary metering rods to see what stamping was on them and discovered Nation carburetor had two different metering rods which I thought had to be the culprit. I ordered a new pair of "DA" rods from ebay and installed them on the "F" hanger and it still bogs.

3. Removed the vacuum brake and plugged the hole with epoxy and drilled a small hole in the epoxy so that it takes about 3 full seconds to open to slow the rate at which the air doors open. It still bogs.

About the only and last thing I can think of was buying a second pair of air doors on ebay and making small notches around the POE holes as I read on the interwebs from a Cliff Ruggles post. I have not done this yet but I see people have (thumbnail attached)

Is there anything else I am over looking or do you think this is just a bad rebuild from National carburetor? I mean the two different secondary rods did not exactly give me the warm and fuzzy feeling from national carburetor.

Id like to dial in this carb rather than go back to a square-bore and adapter. What I would like to do is get a Holley Sniper EFI setup but for now I am stuck with this Quadrajet.

Thanks in advance for any advice.


All times are GMT -5. The time now is 09:24 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.