View Single Post
Old 10-10-2019, 01:26 PM   #8
TaKid455
 
Join Date: Oct 2008
Posts: 553
iTrader: (1)
Always felt 1st gens had a small radiator for what you could stuff into them. Just finished up a 67 w/ a healthy 428 for a customer. Did the aluminum rad w/ 16" fan setup. Haven't had any issues. Went with Cold Case as it was the cost effective of the 2 options I offered. Other options is all custom made. Same stuff the top guys of Drag Week use. I run it in my 78 TA. Cooling issues aren't a concern with that line. Dealer for both companies.

1 - Assuming you have a 180 stat and then removed it?
2 - what radiator specifically?
3 - fan set up? Most are junk w/ even worst shroud designs. When do you have it turning on & off? Should never be on all the time.
4 - water pump impeller clearance to divider plate is important as with the proper sealing of the tubes. Have taken apart problematic engines where the tubes were simply not installed. Did you build the engine? Standard cast impeller?

5- What is your timing set at? Initial and max?
6 - Is the Carb tuned properly? What AFRs are you running?
7 - More of an issue on 2nd gen's where gauge reads funny, but have you confirmed the temps with another tool (rad cap gauge, temp gun , ect) aside from the gauge assuming factory gauges are installed.


8 - Fan is useless above say 40-50 mph.
9 - Front spoiler was not only installed for design but for added air flow in the 400 cars. You should have one and the car will look better too IMO. Baffles are absolutely need . Otherwise air is taking the path of least resistance.
TaKid455 is offline   Reply With Quote